본문 바로가기
3. 웹개발/3_2 Error모음

[React] 'react-scripts'은(는) 내부 또는 외부 명령 실행할 수 있는 프로그램, 또는 배치 파일이 아닙니다.

by 갓대희 2021. 12. 7.
반응형

[React] 'react-scripts'은(는) 내부 또는 외부 명령 실행할 수 있는 프로그램, 또는 배치 파일이 아닙니다.

yarn run, yarn start, npm npm start 모두 다음과 같은 에러를 뱉어 낸다.

 - yarn start 에러

 

 - npm start 에러

 

CLIENT_PLUGIN_AUTH is required

▶ 1. 오류 현상

 - 환경 : mysql 서버 버전 : 5.1.73

 - 접속시도하려는 mysql-connector-java version : 8.0.xx

 

▶ 2. 문제점

 - 원래 yarn에는 start라는 명령어가 없다. yarn start 라는 명령어나 환경변수가 설치되어 있지 않으므로 생기는 에러이다. 
 - yarn start시 yarn run이라고 정의된 명령이 실행되는 것이다. (npm start는 존재하는 명령어)
 - package.json 을 살펴보면 다음과 같은 예시의 스크립트를 볼 수 있는데, 이때문에 react-scripts 명령어가 실행되는걸 볼 수 있다.

ex)npm

"scripts": {
    "start": "react-scripts start",
    "build": "react-scripts build",
    "test": "react-scripts test",
    "eject": "react-scripts eject"
},

 

▶ 3. 해결 방법

1) 문제 프로젝트에 react-script 설치하기

 - npm

npm install -save react-scripts

 - yarn

yarn add react-scripts

 

2) 전역으로 react-scripts 라이브러리 설치하기

 - npm

npm install -g react-scripts

 - yarn

yarn add global react-scripts

 

3) 패키지 매니저 (yarn, npm) 업데이트

※ 다만, 실무 환경이라던지, 기존에 진행중이던 프로젝트가 있는 경우

   다른 패키지들과의 버전이 혹시 맞지 않게 될 수 있으니 추천하진 않는데

 

 - npm

npm update
npm start

 

 - yarn

yarn upgrade
yarn start

 

 

 

 

반응형

댓글0